餐饮管理系统门店JDCT堵包,导致中心下发的数据包不能导入到门店的处理方法
餐饮管理系统门店JDCT堵包,导致中心下发的数据包不能导入到门店的处理方法1
问题现象:
中心下发的档案,门店并没有发生变更,餐饮程序目录:【\Tcsl\CanYin7\data\jcdtclientdata\门店号\receive 】下一直存在数据包不能导入到数据库中
问题原因:
(注:排除门店网络或者数据库本身问题之外的其他原因)
正常程序安装目录【\Tcsl\CanYin7\program\WEB-INF\lib】下有如下图的两个jar文件包,
而客户那边的安装环境对应的目录下多余存在如下图的两个jcdt 不同版本的jar包文件:
导致专门为品项小类图片开发的包无法解包导致后面的数据堵包。
解决方案:
删除多余的版本jar包文件:tcsl-jcdt-client-0.9.26.jar和tcsl-jcdt-common-0.9.23.jar
重启服务后即可解决
餐饮管理系统门店JDCT堵包,导致中心下发的数据包不能导入到门店的处理方法2
问题现象:
中心下发的档案,门店并没有发生变更,餐饮程序目录:【\Tcsl\CanYin7\data\jcdtclientdata\门店号\receive 】下一直存在数据包不能导入到数据库中
问题原因:
低于167版本的程序,门店堵包,是因为总部的员工授权号输入可以超过了10位数字,而门店这个字段长度不能超过10位,导致了数据包导入不进去。
解决方案:
现在临时的解决方式需要将员工档案的包删了(1001开头的包),之前的其他包才能导入进去。彻底解决:需要在总部将员工的授权号调整为少于10位数字的。