设备管理器更新样式报错
问题现象:
在使用设备管理器进行样式下载时报错,错误界面如下图:
现象1:
或直接给出错误的样式id,如下图:
现象2:
问题原因:
以上问题一般是由于本地表中存储的样式记录没有通过总部推送过来(可能已经从总部删除,因设备管理器的样式下载可以主动从总部拉取样式)。
通过设备管理器下载样式时,从\Tcsl\CanYin7\data\style往\AppData\Roaming\Tcsl_DeviceMgr\dmReport下拷贝时找不到对应fr3文件导致报错。
解决方案:
1、确认发生问题的具体样式:
对于现象1中错误信息不够明确的,需要获取设备管理器安装路径下DeviceMgr\Plugin\Logs的dmReport.dll_log日志文件,查看其中的报错信息:
对现象2中已经明确提示出文件id的,可直接进入\AppData\Roaming\Tcsl_DeviceMgr\dmReport(开始运行输入%appdata%),打开report.ini文件,搜索id来定义对应的fr3文件名称:
2、修改门店库:
可按id或名称查询:
select *From canyin.rpt_fr3_style_list where name='客用单-80mm-汇总123'
select *From canyin.rpt_fr3_style_list_new where name='客用单-80mm-汇总123'
将查出来的记录delflg置为2即可。